<!DOCTYPE html>
<html lang="en">
<head>
<title>Rashida Tlaib: Impeach Trump Now - In These Times</title>
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<script type="text/javascript" src="//use.typekit.net/quc7rcb.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>
<link rel="stylesheet" type="text/css" media="all" href="/home/styles" />
<link rel="icon" href="/favicon.ico" type="image/x-icon">
<link rel="alternate" type="application/rss+xml" title="RSS" href="http://www.inthesetimes.com/rss" title="In These Times Magazine" />
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<script>window.twttr = (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0],
    t = window.twttr || {};
  if (d.getElementById(id)) return t;
  js = d.createElement(s);
  js.id = id;
  js.src = "https://platform.twitter.com/widgets.js";
  fjs.parentNode.insertBefore(js, fjs);

  t._e = [];
  t.ready = function(f) {t._e.push(f);};

  return t;
}(document, "script", "twitter-wjs"));</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script type='text/javascript'>
	var googletag = googletag || {};
	googletag.cmd = googletag.cmd || [];
	(function() {
	var gads = document.createElement('script');
	gads.async = true;
	gads.type = 'text/javascript';
	var useSSL = 'https:' == document.location.protocol;
	gads.src = (useSSL ? 'https:' : 'http:') +
	'//www.googletagservices.com/tag/js/gpt.js';
	var node = document.getElementsByTagName('script')[0];
	node.parentNode.insertBefore(gads, node);
	})();
	</script>
<meta property="og:title" content="Rashida Tlaib: Impeach Trump Now" />
<meta name="description" content="Every day that we don’t address corruption, we are setting a precedent and eroding our democracy.">
<meta property="og:description" content="Every day that we don’t address corruption, we are setting a precedent and eroding our democracy." />
<meta property="og:url" content="http://inthesetimes.com/article/21772/rashida-tlaib-impeach-trump" />
<meta property="og:image" content="http://inthesetimes.com/images/made/images/GettyImages-1098004512_500_333_s.jpg" />
<meta content="https://www.facebook.com/inthesetimesmag" property="og:see_also">
<meta content="https://twitter.com/inthesetimesmag" property="og:see_also">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@inthesetimesmag">
<meta name="twitter:creator" content="@inthesetimesmag">
<meta name="twitter:title" content="Rashida Tlaib: Impeach Trump Now">
<meta name="twitter:description" content="Every day that we don’t address corruption, we are setting a precedent and eroding our democracy.">
<meta name="twitter:image" content="http://inthesetimes.com/images/made/images/GettyImages-1098004512_500_333_s.jpg">
<link href="http://inthesetimes.com/article/21772/rashida-tlaib-impeach-trump" rel="canonical">
<link href="http://inthesetimes.com/" rel="home">
<meta property="og:type" content="website">
<script type='text/javascript'>
			googletag.cmd.push(function() {
			googletag.defineSlot('/8507385/ITT.com_Pool_2_LB_1', [728, 90], 'articlelb1').addService(googletag.pubads());
			googletag.defineSlot('/8507385/ITT.com_Pool_2_LB_2', [728, 90], 'articlelb2').addService(googletag.pubads());
			googletag.defineSlot('/8507385/ITT.com_Pool_2_MR', [300, 250], 'articlesq').addService(googletag.pubads());
			googletag.defineSlot('/8507385/ITT.com_Pool_2_MR_2', [300, 250], 'articlesq2').addService(googletag.pubads());
			googletag.defineSlot('/8507385/ITT.com_Splash_Ad', [500, 360], 'splashad').addService(googletag.pubads());
			googletag.pubads().collapseEmptyDivs();
			googletag.pubads().enableSingleRequest();
			googletag.enableServices();
			});
		</script>
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/8507385/Homepage_300x250_2nd', [300, 250], 'div-gpt-ad-1464388143447-0').addService(googletag.pubads());
    googletag.defineSlot('/8507385/Homepage_300x250_TOP', [300, 250], 'div-gpt-ad-1464388143447-1').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script type="text/javascript">
 window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
!function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
}(document.createElement('script'), document.getElementsByTagName('script')[0], 'https://cdn.taboola.com/libtrc/inthesetimes/loader.js');
</script>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js"></script>
<script type="text/javascript" src="/js/social-likes.min.js"></script>
<link rel="stylesheet" type="text/css" href="/global/jquery/fancybox/jquery.fancybox-1.3.4.css" media="screen" />
<script src="http://inthesetimes.com/cache/293299efca93c18228a4943fac7473a78d26384b.1383786710.js" type="text/javascript"></script>
<script type="text/javascript">
	$(document).ready(function(){
		$('.sf-menu').superfish({
    		speed: 'fast',
    		speedOut: 'fast'
    	});
	    $('.mobile-menu .button > a').click(function () {
	        $('.mobile-menu ul').toggle();
	        return false;
	    });
	    $('.mobile-comments').click(function () {
	        $('.article-comment').slideDown("fast");
	        $('.mobile-comments').hide();
	        return false;
	    });
		$('.moreby, .sechead-blog-about').waypoint(function(direction) {
		   if (direction === 'down') {
		      $('#next_article').stop().show();
		      $('#next_article a').stop().animate({"margin-top": 10}, 60);
		   }
		   else {
		        $('#next_article').stop().animate({"right": -310}, 60);
		        $('#next_article .close').hide();
		        $('#next_article .expand').show();
			   offset: '70%'  // trigger at middle of page.
		   }

		},{
		  offset: 750
		});
    $('#next_article .close').click(function(){
        $('#next_article').stop().animate({"right": -310}, 60);
        $('#next_article .close').hide();
        $('#next_article .expand').show();
      return false;
    });
    $('#next_article .expand').click(function(){
        $('#next_article').stop().animate({"right": -10}, 60);
        $('#next_article .expand').hide();
        $('#next_article .close').show();
      return false;
    });


	});

	</script>
<script>(function(d, s, id) {
	  var js, fjs = d.getElementsByTagName(s)[0];
	  if (d.getElementById(id)) return;
	  js = d.createElement(s); js.id = id;
	  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=131045860307381";
	  fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));</script>

<script type='text/javascript'>
var _vwo_code=(function(){
var account_id=68119,
settings_tolerance=2000,
library_tolerance=2500,
use_existing_jquery=false,
// DO NOT EDIT BELOW THIS LINE
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
</script>


<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '567012490133474'); // Insert your pixel ID here.
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=567012490133474&ev=PageView&noscript=1"
/></noscript>


</head>
<body id="" class="subpage">
<div id="fb-root"></div>
<div id="wrapper">
<header>
<div class="ad" style="display: none;">

<div id='articlelb1'>
<script type='text/javascript'>
				googletag.cmd.push(function() {googletag.display('articlelb1');});
				</script>
</div>
</div>
<div class="holder row">
<div class="eighteen columns">
<div class="logo"><a href="/">In These Times</a>
</div>
<div style="margin-bottom: 10px;">
<form class="search" action="https://inthesetimes.com/search/results">
<fieldset>
<nav class="social">
<a href="http://www.inthesetimes.com/rss" class="feed">RSS</a>
<a href="https://facebook.com/InTheseTimesMag" class="facebook">Facebook</a>
<a href="https://twitter.com/InTheseTimesMag" class="twitter">Twitter</a>
</nav>
<input type="hidden" name="cx" value="001426508291867289762:j9oedch9yge" />
<input type="hidden" name="cof" value="FORID:11" />
<input type="hidden" name="ie" value="UTF-8" />
<input type="text" name="q" class="text" />
<input class="btn" type="submit" value="SEARCH" />
</fieldset>
</form>
</div>
<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
</div>
</div>
<div class="mobile-menu">
<div class="button"><a href="#">▼</a></div>
<ul id="nav">
<li><a href="/politics/">POLITICS</a></li>
<li><a href="/act-locally/">ACT LOCALLY</a></li>
<li><a href="/labor/">LABOR</a></li>
<li><a href="/culture/">CULTURE</a></li>
<li><a href="/features/stranded_by_the_state_video_illinois_budget_crisis_rauner.html">VIDEO</a></li>
<li><a href="/archives/">CURRENT ISSUE</a></li>
<li><a href="/contributors/">Contributors</a></li>
<li><a href="http://www.inthesetimes.com/menu-mobile-subscribe-01">SUBSCRIBE</a></li>
<li><a href="/donate">DONATE</a></li>
<li><a href="/about/">About Us</a></li>
<li><a href="/contact/">Contact Us</a></li>
<li><a href="/newsletters/">Free Newsletters</a></li>
</ul>
</div>
<ul id="nav" class="sf-menu">
<li><a href="/" class="active">HOME</a></li>
<li><a href="/politics/">POLITICS</a><ul><li><a href="/article/21769/queens-dsa-district-attorney-race-Tiffany-Caban-endorsement-AOC">
The Queens DSA Helped Elect AOC. Next Up: The District Attorney Race.</a></li><li><a href="/article/21788/obama-my-brothers-keeper-assatas-daughters-black-feminism-youth-scolding">
Young Black Feminists Have Some Pointers for Obama</a></li><li><a href="/article/21785/venezuela-guaido-maduro-lima-group-pence-trump-coup-chavista-opposition">
Another Failed Coup in Venezuela?</a></li><li><a href="/article/21784/dianne-feinstein-green-new-deal-ocasio-cortez-climate-change-sunrise">
Why Is Dianne Feinstein So Opposed to the Green New Deal? Look at Her Family Finances.</a></li><li><a href="/article/21778/false-accusations-antisemitism-ilhan-omar-israel-palestine-democrats">
Why False Accusations of Anti-Semitism Against Ilhan Omar Are So Harmful</a></li>
</ul></li>
<li><a href="/act-locally/">ACT LOCALLY</a><ul><li><a href="/article/21788/obama-my-brothers-keeper-assatas-daughters-black-feminism-youth-scolding">
Young Black Feminists Have Some Pointers for Obama</a></li><li><a href="/article/21728/progressive-2020-presidential-candidates-social-movements-accountable">
It&#8217;s Not Enough To Elect Progressives&#8212;Movements Must Have a Role in Governing</a></li><li><a href="/article/21731/amazon-hq2-sweepstakes-Nashville">
New York Isn&#8217;t the Only City Waging a Fight Against Amazon</a></li><li><a href="/article/21745/texas-activists-thought-theyd-kicked-ice-out-of-their-county.-then-a-secret">
Texas Activists Thought They&#8217;d Kicked ICE Out of Their County. Then a Secret Deal Happened.</a></li><li><a href="/article/21729/yellow-vests-occupy-movement-paris-france-protests">
What the Yellow Vests Have in Common with Occupy</a></li>
</ul></li>
<li><a href="/labor/">LABOR</a><ul><li><a href="/article/21733/feminism-age-of-precarity-Alice-Kessler-Harris-women-workplace-demands">
Feminism in the Age of Precarity</a></li><li><a href="/article/21713/stock-buy-back-wealth-workers-shareholders-nike-amazon-visa-express">
Instead of Enriching Shareholders, These Companies Could Give 8 Million Workers a $46,000 Raise</a></li><li><a href="/article/21684/los-angeles-teachers-strike-education-charter-privatization-la">
&#8220;Welcome to the Revolution&#8221;: LA Teachers Strike Pits Working-Class Power Against Privatization</a></li><li><a href="/article/21661/public-sector-unions-response-to-janus">
Disaster Averted: How Unions Have Dodged the Blow of Janus (So Far)</a></li><li><a href="/article/21645/left-victories-2018-new-year-medicare-for-all-ocasio-cortez-green-new-deal">
The Left Victories That Defined 2018&#8212;And Give Us Hope for the New Year</a></li>
</ul></li>
<li><a href="/culture/">CULTURE</a><ul><li><a href="/article/21669/anthropology-humanity-survival-cultural-diversity">
There&#8217;s a Vanishing Resource We&#8217;re Not Talking About</a></li><li><a href="/article/21666/wealth-tax-super-wealthy-rich-fortune-trust-funds">
A Tax the Rich Can&#8217;t Avoid</a></li><li><a href="/article/21670/eldercare-america-emigrating-germany-healthcare-costs-nursing-homes">
Emigrating From the U.S. May Be the Only Way To Afford Eldercare</a></li><li><a href="/article/21657/black-lives-matter-elections-Barbara-Ransby-freedom-fighters">
Black Lives Matter. Do Elections?</a></li><li><a href="/article/21668/racism-obama-black-president-trump-democrats-race">
Racism After the First Black President</a></li>
</ul></li>
<li><a href="/features/stranded_by_the_state_video_illinois_budget_crisis_rauner.html">VIDEO</a></li>
<li><a href="/archives/covers_ind/43/03/">MAGAZINE</a><ul>
<li><a href="http://www.inthesetimes.com/menu-subscribe-01">SUBSCRIBE</a></li>
<li><a href="/gift-subscriptions">GIVE A GIFT</a></li>
<li><a href="/archives/covers_ind/43/03/">CURRENT ISSUE</a></li>
<li><a href="/archives">ARCHIVES</a></li>
<li><a href="https://w1.buysub.com/pubs/IF/ITT/login_singlemag_noCAPTCHA.jsp?cds_page_id=145923&cds_mag_code=ITT&id=1397147639372&lsid=41001129112048830&vid=3">CUSTOMER SERVICE</a></li>
</ul></li>
<li><a href="/donate" class="active">DONATE</a></li>
</ul>
</header>
<section class="content">
<div class="rules"><div class="one"></div><div class="two"></div></div>
<article class="columns">
<div class="showblock"></div>
<div class="feature">
<div class="image">
<a href="/article/21772/rashida-tlaib-impeach-trump"><img src="/images/made/images/GettyImages-1098004512_850_567.jpg" width="850" height="567" alt="" /></a>
<p class="photo-caption">Trump has got to go. (NICHOLAS KAMM/AFP/Getty Images)</p>
</div>
<h5 class="article-dateline">
Views &raquo; March 13, 2019
</h5>
<h1 class="article-headline">Rashida Tlaib: Impeach Trump Now</h1>
<p class="article-deck">Every day that we don’t address corruption, we are setting a precedent and eroding our democracy.</p>
<span class="author">BY <a href="/community/profile/323192">Rashida Tlaib</a></span>
<script type="text/javascript"><!--
$(document).ready(function(){
	$('.email, .zoom').fancybox({
				'overlayColor'		: '#000',
				'overlayOpacity'	: 0.7
			});
});
//-->
</script>
<div class="buttons">
<div class="sharebuttons social-likes">
<a href="http://www.facebook.com/share.php?u=http://inthesetimes.com/article/21772/rashida-tlaib-impeach-trump" data-url="http://inthesetimes.com/article/21772/rashida-tlaib-impeach-trump" class="facebook fb"> <span>Share</span></a><a href="http://twitter.com/intent/tweet?url=http://inthesetimes.com/article/21772/rashida-tlaib-impeach-trump" data-url="http://inthesetimes.com/article/21772/rashida-tlaib-impeach-trump" class="tw twitter"> <span>Tweet</span></a><a href="http://www.reddit.com/submit?url=http://inthesetimes.com/article/21772/rashida-tlaib-impeach-trump&title=Rashida Tlaib: Impeach Trump Now" class="reddit"><span>Reddit</span><span class="social-likes__counter">0</span></a>

<a href="#contact" class="email"><span>Email</span><span class="social-likes__counter"></span></a><a href="/article/print/21772/rashida-tlaib-impeach-trump" class="print" onclick="window.open(this.href,'targetWindow','toolbar=no,location=no,status=no,menubar=no,scrollbars=yes,resizable=yes,width=730,height=900'); return false;"><span>Print</span><span class="social-likes__counter"></span></a>
</div>
<div style="display:none;">
<div id="contact" style="width:520px;height:240px;overflow:auto;">
<form id="tellafriend_form" method="post" action="http://inthesetimes.com/">
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="16" />
<input type="hidden" name="RET" value="" />
<input type="hidden" name="URI" value="article/21772/rashida-tlaib-impeach-trump" />
<input type="hidden" name="recipients" value="xKejq7azMdJ5dWmC9RXeho64ZQpObYFukOfoISudfsk=" />
<input type="hidden" name="user_recipients" value="8144ca9f028945264a321ee52aae5456" />
<input type="hidden" name="charset" value="utf-8" />
<input type="hidden" name="redirect" value="" />
<input type="hidden" name="replyto" value="" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="207320e8297f139b8d3aa4749121ff1fa7c9f5c2" />
</div>
<h3>Email this article to a friend</h3>
<fieldset>
<p><label for="email">your email</label> <input type="text" name="from" class="input" value="" /></p>
<p><label for="name">your name</label> <input type="text" name="name" value="" class="input" /></p>
<p><label for="subject">recipient(s) email (comma separated)</label> <input type="text" class="input" name="to" /></p>
<input type="hidden" name="subject" value="Rashida Tlaib: Impeach Trump Now - In These Times" /><input type="hidden" name="RET" value="http://inthesetimes.com/article/21772/rashida-tlaib-impeach-trump/" /></p>
</fieldset>
<fieldset class="right">
<p><label for="message">message</label>
<textarea name="message[]" rows="18" cols="40"></textarea></p>
<input type="hidden" name="message[]" value='

---------------------
Rashida Tlaib: Impeach Trump Now
By Rashida Tlaib

http://inthesetimes.com/article/21772/rashida-tlaib-impeach-trump/
' />
<p class="captcha"><label>captcha</label>
<img src="http://www.inthesetimes.com/images/captchas/1552514322.2914.jpg" width="140" height="30" style="border:0;" alt=" " /> <input type="text" name="captcha" value="" class="input" /></p>
</fieldset>
<p><input name="submit" class="submit" type='submit' value='Send Email' /></p></form>
</div>
</div>
</div>
<div class="content-body">
<div id="article-inset">
<p class="pullquote">Trump’s years in office are years we cannot get back.</p>
</div>
<p>Now is the time for impeachment.</p>
<p>People in D.C. ask: What would it mean for our 2020 strategy? But I ask what it means for the people I grew up with, the residents of my district, and what it means for all of us, as Americans, to have Donald Trump remain our president.</p>
<p>Trump&rsquo;s years in office are years we cannot get back. But more dangerous than the loss of time is allowing Trump&rsquo;s precedents to take root.</p>
<p>In 2017, Trump pardoned Joe Arpaio, an Arizona sheriff who was ordered by a federal court to stop racially profiling and was convicted of criminal contempt when he refused. Arpaio, by targeting Latinx people, was violating both the U.S. Constitution and our civil rights. Trump&rsquo;s pardon of Arpaio may not get as much attention as Russian influence, or Trump&rsquo;s apparent obstruction of justice in the Mueller investigation. But to me, as a woman of color, it is a clear abuse of power for the U.S. president to pardon a sheriff who targeted people for arrest because of their ethnicity. In other words, that act alone warrants its own congressional hearing.</p>
<p>It&rsquo;s not just the racist words Trump uses&mdash;which are very painful and do incite violence&mdash; but his racist actions, which undermine our Constitution.</p>
<p>It&rsquo;s bad enough that Trump&rsquo;s Muslim ban dehumanizes&nbsp;people based on their religion and nationality, but constitutional scholars have also argued the Muslim ban <a href="https://constitutioncenter.org/blog/trump-and-the-constitution-a-year-in-review-and-our-coverage" target="_blank">violates</a> the First Amendment&rsquo;s separation of church and state. Among countless examples of Trump&rsquo;s racism and xenophobia, he has even turned his ire against Americans: In February, a judge ruled that Trump&rsquo;s withholding of disability benefits from Puerto Ricans was unconstitutional, calling it &ldquo;citizenship apartheid.&rdquo; Most recently, to push through his racist border wall, Trump declared an unconstitutional state of emergency.</p>
<p>Add to this precedent what&rsquo;s happening to immigrants. As a child, I never could have imagined that when I was 42, my country would be caging children at its border.</p>
<p>Trump is setting another disturbing precedent by refusing to divest from his businesses&mdash;on top of his refusal to even disclose what his business interests are. Having a sitting president, who knows his position is temporary, with a stake in more than 500 businesses is a recipe for corruption. Today, both at home and around the world, there is a sense that if you want to do business with the United States of America, you&rsquo;ve got to spend money with the Trump Organization. Citizens for Responsibility and Ethics in Washington (CREW) documented more than <a href="https://www.citizensforethics.org/presidential-profiteering-trumps-conflicts-got-worse/" target="_blank">1,400 interactions</a> in 2017 and 2018 that represented conflicts of interest for Trump, including his 281 visits to properties he profits from. Twelve foreign governments made payments to Trump&mdash;each of which, according to CREW, &ldquo;is likely a violation of the Constitution&rsquo;s foreign emoluments clause,&rdquo; which bans presidents from receiving gifts from foreign countries.</p>
<p>The emoluments clause is in the Constitution for a reason: We, as Americans, need to know that the president acts in our best interests, not his own self-interest. When Trump refused to censure Saudi Crown Prince Mohammed bin Salman for the murder of journalist Jamal Khashoggi, was he doing so on our behalf or because the Saudi government had spent $270,000 at a Trump hotel?</p>
<p>The president of the United States and his associates are implicated in multiple crimes to get him elected. Trump&rsquo;s close friend, <em>National Enquirer</em> owner David Pecker, and Trump&rsquo;s personal lawyer, Michael Cohen, made payments to two women to purposefully influence an election&mdash;criminal felonies, both directed by Trump himself. One could write a blockbuster thriller about all the&nbsp;transgressions and it still wouldn&rsquo;t be more terrifying than the threats to our bedrock democratic principles.</p>
<p>Such actions are morally unacceptable. And it is irresponsible for members of Congress to ignore these transgressions because of their political calculations or worries about 2020.</p>
<p>The people I represent in the 13th Congressional District are not talking about &ldquo;the Russians.&rdquo; They are not talking about the Mueller investigation. Some of them don&rsquo;t even know who Mueller is or what the investigation is about. Rather, they ask, &ldquo;How come Trump hasn&rsquo;t shown his tax returns?&rdquo; One resident of my district described Trump as &ldquo;a crooked CEO in the White House, running his businesses from the Oval Office.&rdquo; That, to me, is what scares the American people, and rightfully so.</p>
<p>This corruption in our democracy creates anxiety. That&rsquo;s why people like me got elected. People want someone who will represent them fearlessly and unapologetically. They want someone to say, &ldquo;That&rsquo;s wrong. That&rsquo;s illegal. And we need to fix it right away.&rdquo;</p>
<p>Our situation as a nation is urgent. It is time for a call for impeachment to set the tone. We have enough information to move forward.</p>
<p>We cannot permit Donald Trump to commit crimes from the Oval Office or violate our Constitution in broad daylight and get away with it. Such actions are criminal.</p>
<p>When Trump became president, he started working for us. He works for the people.</p>
<p>We handed him that power. We can take it back.</p>


<div class="moreby">
<a href="/community/profile/323192/"><img src="/images/made/images/member_photos/photo_323192_75_75_c1.jpg" width="75" height="75" alt="" />
 <h2 class="sechead-article-author">Rashida Tlaib</h2></a>
<p>Rashida Tlaib is the U.S. representative for Michigan’s 13th congressional district. She is a lawyer and served as a state representative in Michigan for six years. </p>
</div>
<div class="checkout">
<h3>if you like this, check out:</h3>
<ul>
<li>
<a href="/article/21723/alexandria-ocasio-cortez-rashida-tlaib-shirley-chisholm-ella-baker">Not Here To Behave: What Alexandria Ocasio-Cortez and Shirley Chisholm Have in Common</a>
</li>
<li>
<a href="/article/21761/donald-trump-border-wall-national-emergency-congress-secure-fence-act">Trump&#8217;s Deranged Border Wall Plan, In 11 Statistics</a>
</li>
<li>
<a href="/article/21734/third-way-democrats-trump-reelected-2020-new-democracy-PAC">How Third Way Democrats Could Get Trump Re-elected</a>
</li>
<li>
<a href="/article/21728/progressive-2020-presidential-candidates-social-movements-accountable">It&#8217;s Not Enough To Elect Progressives&#8212;Movements Must Have a Role in Governing</a>
</li>
<li>
<a href="/article/21753/open-borders-donald-trump-freedom-of-movement-democrats-free-trade">Open Borders, Without Apology</a>
</li>
</div>
<div id='taboola-below-main-column-mix'></div>
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({mode:'thumbs-2r', container:'taboola-below-main-column-mix', placement:'below-main-column', target_type:'mix'});
</script>
<script>
window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
_taboola.push({flush:true});
</script>
<a href="#" class="mobile-comments">View Comments</a>
<div class="article-comment">
<div id="disqus_thread"><noscript></noscript></div>
<script type="text/javascript">
	var disqus_shortname = "inthesetimes";
	var disqus_identifier = "21772";
	var disqus_title = "Rashida Tlaib: Impeach Trump Now";
	(function() {
		var dsq = document.createElement("script"); dsq.type = "text/javascript"; dsq.async = true;
		dsq.src = "https://" + disqus_shortname + ".disqus.com/embed.js";
		(document.getElementsByTagName("head")[0] || document.getElementsByTagName("body")[0]).appendChild(dsq);
	})();
	(function() { if (window.XMLHttpRequest) {
		var xmlhttp = new XMLHttpRequest(); xmlhttp.open("GET", "http://inthesetimes.com/?ACT=109&sync=600", true); xmlhttp.send();
	}})();
</script>
</div>
</article>
<aside class="sidebar columns">
<div class="block cover">
<div style="overflow: hidden;">
<a href="http://inthesetimes.com/archives/covers_ind/43/03/"><img src="/images/made/images/made/images/43/03/cover4303_104_136_104_136_65.jpg" width="104" height="136" alt="" /></a> <ul>
<li><a href="/article/21732/street-art-murals-corporations-advertising-los-angeles-muralism-graffiti">Street Art Used To Be the Voice of the People. Now It&#8217;s the Voice of Advertisers.</a></li>
<li><a href="/article/21733/feminism-age-of-precarity-Alice-Kessler-Harris-women-workplace-demands">Feminism in the Age of Precarity</a></li>
<li><a href="/article/21723/alexandria-ocasio-cortez-rashida-tlaib-shirley-chisholm-ella-baker">Not Here To Behave: What Alexandria Ocasio-Cortez and Shirley Chisholm Have in Common</a></li>
<li><a href="/article/21761/donald-trump-border-wall-national-emergency-congress-secure-fence-act">Trump&#8217;s Deranged Border Wall Plan, In 11 Statistics</a></li>
<li class="full"><a href="/archives/covers_ind/43/03/">View Full Contents</a></li>
</ul>
</div>
<div class="disclaimer"><a href="http://www.inthesetimes.com/sn-cover-subscribe-01" class="button">Subscribe to In These Times</a>
<p>Only $20/year&mdash;that's only $1.67 per month!</p></div>
</div>
<div class="block">
<h4>MOST READ</h4>
<ol><li><a href="http://inthesetimes.com/article/21732/street-art-murals-corporations-advertising-los-angeles-muralism-graffiti">Street Art Used To Be the Voice of the People. Now It’s the Voice of Advertisers. </a></li><li><a href="http://inthesetimes.com/article/21789/venezuela-maduro-trump-barrios-intervention-sanctions-chavismo-guaido">A Call for Clear Heads on Venezuela: How To Criticize Maduro While Opposing U.S. Regime Change </a></li><li><a href="http://inthesetimes.com/article/21773/socialism-leigh-phillips-michal-rozworski-peoples-republic-of-walmart">Could Walmart Be a Model for a Socialist Future? </a></li><li><a href="http://inthesetimes.com/working/entry/21791/green-new-deal-climate-change-labor-common-good-bargaining-permissive">Why Unions Must Bargain Over Climate Change</a></li><li><a href="http://inthesetimes.com/article/21784/dianne-feinstein-green-new-deal-ocasio-cortez-climate-change-sunrise">Why Is Dianne Feinstein So Opposed to the Green New Deal? Look at Her Family Finances. </a></li></ol>
</div>
<div style="clear: both;"></div>
<hr style="background-color: #000000 !important; color: #000000 !important; height: 7px !important; margin-top: 0px; margin-bottom: 15px;">
<div style="padding: 10px 0px 0px 0px; width: 100%;">
<center>
<a href="https://secure.actblue.com/donate/itt-subscription-offer-20181008-ws?refcode=20181010_WS_Sidebar&recurring=true" target="_blank"><img src="http://inthesetimes.com/offers/images/Cover_4211.jpg" style="width: 100%;"></a>
<div style="padding: 10px 0px 0px 0px;">
<center>
<p style="font-family: franklin-gothic-urw,sans-serif; font-size: 15px; line-height: 17px; color: #000000; text-transform: uppercase; font-weight: bold; margin-top: -5px; margin-bottom: 10px;">Limited Time: Subscribe to IN THESE TIMES MAGAZINE for just $1 a month</p>
<a class="sidebar_button" style="color: #000000; margin-bottom: 20px;" href="https://secure.actblue.com/donate/itt-subscription-offer-20181008-ws?refcode=20181010_WS_Sidebar&recurring=true">Try for $1</a>
</center>
</div>
</center>
</div>
<hr style="background-color: #000000 !important; color: #000000 !important; height: 7px !important; margin-top: 0px; margin-bottom: 15px;">

<div id='articlesq'>
<script type='text/javascript'>
			googletag.cmd.push(function() {googletag.display('articlesq');});
			</script>
</div>
<h4 class="sidelatest">Get the Latest News & Updates</h4>
<script type="text/javascript" src="https://inthesetimes.formstack.com/forms/js.php/newsletter_splash_5"></script><noscript><a href="https://inthesetimes.formstack.com/forms/newsletter_splash_5" title="Online Form">Online Form - Newsletter splash 5</a></noscript>


<hr>
<center>
<div class="facebook-side">
<div class="fb-like-box" data-href="https://www.facebook.com/inthesetimesmag" data-colorscheme="light" data-show-faces="true" data-header="true" data-stream="false" data-show-border="false"></div>
</div>

<div id='articlesq2'>
<script type='text/javascript'>
			googletag.cmd.push(function() {googletag.display('articlesq2');});
			</script>
</div>
</center>
<hr>
<div style="padding: 0px;"><a href="http://inthesetimes.com/offers/age-of-inequality-book.html?refcode=WS_sidebar&noskip=true"><img src="https://can2-prod.s3.amazonaws.com/uploads/data/000/080/630/original/aoi_email_01.jpg" width="100%"></a></div>
<div style="padding: 10px 0px 0px 0px;">
<center>
<p style="font-family: franklin-gothic-urw,sans-serif; font-size: 15px; line-height: 17px; color: #000000; text-transform: uppercase; font-weight: bold; margin-top: -5px; margin-bottom: 10px;">The stories behind the inequality crisis&mdash;from <em>In These Times</em> and Verso Books</p>
<a class="sidebar_button" style="color: #000000;" href="http://inthesetimes.com/offers/age-of-inequality-book.html?refcode=WS_sidebar&noskip=true">Learn More</a>
</center>
</div>
</aside>
</section>
<div id="next_article">
<a href="#" class="close">x</a>
<a href="#" class="expand">«</a>
<a href="/article/21723/alexandria-ocasio-cortez-rashida-tlaib-shirley-chisholm-ella-baker" class="article">
<h3>Read this next</h3>
<p>Not Here To Behave: What Alexandria Ocasio-Cortez and Shirley Chisholm Have in Common</p></a>
</div>
<footer>
<div class="row">
<div class="five columns">
<a href="/" class="footer-logo">In These Times</a>
</div>
<div class="thirteen columns">
<ul>
<li><a href="/about/">ABOUT US</a></li>
<li><a href="/newsletters/">NEWSLETTERS/RSS</a></li>
<li><a href="/contact/">CONTACT US</a></li>
<li><a href="/reprints">REPRINTS</a></li>
<li><a href="/archives/">ARCHIVES</a></li>
<li><a href="/submissions/">SUBMISSIONS</a></li>
<li><a href="/donate">DONATE</a></li>
<li><a href="/leave-legacy/">LEAVE A LEGACY</a></li>
<li><a href="/sponsorship/">SPONSORSHIPS</a></li>
<li><a href="/advertise/">ADVERTISE</a></li>
<li><a href="/press-releases/">PRESS</a></li>
<li><a href="/privacy-policy/">PRIVACY POLICY</a></li>
<li><a href="/subscribe/">SUBSCRIBE</a></li>
<li><a href="/gift-subscriptions">GIVE A GIFT</a></li>
<li><a href="/internships-jobs/">INTERNSHIPS/JOBS</a></li>
<li><a href="/investigative/">INVESTIGATIVE INSTITUTE</a></li>
</ul>
</div>
</div>
<p>COPYRIGHT &copy;2018 IN THESE TIMES AND THE INSTITUTE FOR PUBLIC AFFAIRS. ALL RIGHTS RESERVED</p>
</footer>
</div>
<script type="text/javascript">
  (function() {
    var li = document.createElement('script'); li.type = 'text/javascript'; li.async = true;
    li.src = ('https:' == document.location.protocol ? 'https:' : 'http:') + '//platform.stumbleupon.com/1/widgets.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(li, s);
  })();
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-85806-1', 'inthesetimes.com');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script>
</body>
</html>
